How to Install Visual Studio Code in Ubuntu, Mint, Elementary

By | May 12, 2015

Announced at the Build 2015 event, Microsoft has been launched a desktop code editor application called Visual Studio Code, Thanks to Microsoft for release a cross-platform code editor that runs on Linux (also with Windows and Mac OS X).

In this post we will take a quick look what is Visual Studio Code and how to install it in Ubuntu, Mint, and Elementary OS.

What’s in Visual Studio Code ?

Visual Studio Code has been built with a mix of open-source and web-based technologies, like GitHub Electron app framework and Chromium. The tool is not a fully fledged IDE (Integrated Development Environment).

Visual Studio Code supports full syntax coloring and highlighting, bracket matching and linting, keyboard bindings and keyboard snippets.

It also have GitHub Integration and IntelliSense Support powered by open-source projects for faster working.

Programming languages that currently supported by Visual Studio Code are:

  • C++
  • C#
  • PHP
  • HTML
  • JSON
  • Markdown
  • SASS
  • Python
  • Java
  • JavaScript

Keep in mind this Visual Studio Code is on alpha status, so keep an eye for every updates for new features.

How to Install Visual Studio Code in Ubuntu

Visual Studio Code is currently in preview, so possibly buggy, error features, missing features, but if you want to it’s available to Download for free on Linux, Windows and Mac.

For Linux its only provided 64-bit binary and it runs from it’s own folder.

Download Visual Studio Code (64-bit only)

Visual Studio Code also available to install using Ubuntu Make, a handy set of CLI tools for quickly installing the IDEs. To install Visual Studio Code through Ubuntu Make, you need to run the following commands:

$ sudo add-apt-repository ppa:ubuntu-desktop/ubuntu-make
$ sudo apt-get update && sudo apt-get install ubuntu-make
$ umake web visual-studio-code

2 thoughts on “How to Install Visual Studio Code in Ubuntu, Mint, Elementary

  1. René

    Hello mister Yani Hidayat,

    Why cant i only use 64bit ?

    Thank you,

    René

    Reply

Leave a Reply to Rahmat Yani Hidayat Cancel reply

Your email address will not be published. Required fields are marked *